
  


<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.postguam.com/content/tncms/live/" />
<meta name="keywords" content="riten peter, last respects, christianity, memorial, yona, interment, mangilao, viewing" />
<meta name="news_keywords" content="riten peter, last respects, christianity, memorial, yona, interment, mangilao, viewing" />
<meta name="description" content="Reverend Riten Peter, of Mangilao, died Jan. 2 at the age of 68. Viewing and last respects will be held from 9 a.m.-noon on Jan. 19 at Our Lady of" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="google-site-verification" content="nfNIFPIqQ1BOTqA2bfvz8McdmeVbjy2D2HUqgX8AlJQ" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.postguam.com/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&amp;resize=308%2C400&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="308" />
<meta property="og:image:height" content="400" />
<meta property="og:title" content="Reverend&nbsp;Riten Peter" />
<meta property="og:description" content="Reverend Riten Peter, of Mangilao, died Jan. 2 at the age of 68. Viewing and last respects will be held from 9 a.m.-noon on Jan. 19 at Our Lady of" />
<meta property="og:site_name" content="The Guam Daily Post" />
<meta property="og:section" content="Obituaries" />
<meta property="fb:app_id" content="1042428082466551" />
<meta property="article:publisher" content="https://www.facebook.com/postguam" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@postguam" />
<meta name="twitter:image:alt" content="Reverend Riten Peter" />
<meta property="fb:pages" content="269007167849" />
<meta property="tncms:ads" content="smart,lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.2a76ea6b1da821b015c6c6168e530f02.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.c9c732b035a293475d6df8121863ef5a.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=NTR|Lora:400,700|PT+Sans:400,700|Open+Sans:400,700|Source+Serif+Pro:400"/>
<link rel="stylesheet" href="https://use.typekit.net/ipw6blv.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"simple","style":"default","path":"\/obituaries","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"infinity_scroll":{"display":"summary_siderail","order":"next"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":226},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"6b37c6bc-5583-11eb-b85c-3b24571429a2","app":"editorial"},"google":{"ua":"UA-93000716-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/13632/cc.js?ns=_cc13632" id="LOTCC_13632"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc13632.add('tp', 'TNNW');
		_cc13632.add('act', ' User Login');
		_cc13632.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc13632.bcp();
</script>

<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://cdn.districtm.ca/merge/all.townNews.js"></script>
<script src="https://tagan.adlightning.com/townnews/op.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["riten peter","last respects","christianity","memorial","yona","interment","mangilao","viewing"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/postguam.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.7047e23fde50ef7dc7625903de95abec.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/postguam.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/postguam.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/postguam.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/postguam.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/postguam.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        stickyAnchor:"https:\/\/bloximages.newyork1.vip.townnews.com\/postguam.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.834cbe7aa25c4d789bfb4c362348b677.js",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/postguam.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/postguam.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/postguam.com/obituaries';
            
                gptAdSlots['ad-776815'] = googletag.defineSlot(adUnit, [1,1], 'ad-776815').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-776815'].setTargeting('pos', ['gdp-reveal-main']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/postguam.com/obituaries';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [728,90]).addSize([992, 0], [[728,90], [970,90], [970,250]]).addSize([1200, 0], [[728,90], [970,90], [970,250]]).build();
                gptAdSlots['ad-723284'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90],[970,250]], 'ad-723284').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-723284'].setTargeting('pos', ['leaderboard-top']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script>/*<![CDATA[*/ window.poll_config || (window.poll_config = []); window.poll_config.push({"id":"8c816caa-51a1-11eb-baa9-eb130e7fb2c6-700870","asset_id":"8c816caa-51a1-11eb-baa9-eb130e7fb2c6","title":"Do you agree with changing Guam\\'s senatorial jobs to part-time?","url":"\/do-you-agree-with-changing-guams-senatorial-jobs-to-part-time\/poll_8c816caa-51a1-11eb-baa9-eb130e7fb2c6.html","results":"https:\/\/www.postguam.com\/do-you-agree-with-changing-guams-senatorial-jobs-to-part-time\/poll_8c816caa-51a1-11eb-baa9-eb130e7fb2c6.html?action=poll:results&format=json","chart":"bar"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/postguam.com/obituaries';
            var mapping = googletag.sizeMapping().addSize([320, 0], [300, 250]).addSize([768, 0], [[300, 250], [300, 600]]).addSize([992, 0], [[300, 250], [300, 600]]).addSize([1200, 0], [[300, 250], [300, 600]]).build();
                gptAdSlots['ad-723290'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-723290').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-723290'].setTargeting('pos', ['right-rail-skyscraper-1']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/postguam.com/obituaries';
            
                gptAdSlots['ad-723291'] = googletag.defineSlot(adUnit, [300, 250], 'ad-723291').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-723291'].setTargeting('pos', ['right-rail-banner-1']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/postguam.com/obituaries';
            
                gptAdSlots['ad-723292'] = googletag.defineSlot(adUnit, [300, 250], 'ad-723292').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-723292'].setTargeting('pos', ['right-rail-banner-2']);
    });
 /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.waypoints.1115c65bd62165d952fac7c1b6918b2a.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Reverend Riten Peter | Obituaries | postguam.com</title>
            
    <style>body { background-color: #fff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #2a2a2a; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #fff; } .fixed-nav #main-navigation { background-color: #fff !important; } #site-top-nav-container, #site-top-nav { background-color: #1e1a1c; } #site-footer-container, #site-footer { background-color: #1e1a1c; color: #F5F0F0; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #2a2a2a; } .navbar-toggle .icon-bar { background-color: #2a2a2a !important; } .navbar-toggle .sr-only-show { color: #2a2a2a !important; } #site-top-nav .list-inline>li>a { color: #fff; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #2a2a2a; } }#site-copyright a, #site-footer a { color: #F5F0F0; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #2a2a2a; }#site-header-container{ border-bottom: 3px solid #2a2a2a; }#site-footer-container{ border-top: 3px solid #2a2a2a; } .tnt-bg-accent { background-color: #2a2a2a; } a .tnt-caret-down { color: #2a2a2a; } .block-title .block-title-inner { border-color: #2a2a2a; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #2a2a2a; } .form-control:focus { border-bottom-color: #2a2a2a; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.postguam.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//cdn.districtm.ca">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Reverend Riten Peter | Obituaries | postguam.com" href="http://www.postguam.com/search/?f=rss&amp;t=article&amp;c=obituaries&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.postguam.com/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            

<script type="text/javascript">
var sTemp = '/obituaries';
$(document).ready(function(){

//console.log('::::::::::::::::++'+sTemp);


$('.asset-comments.hidden-print').insertBefore('.asset-recommend.outbrain.hidden-print');

$("#adowl-field-contact-state").val("GU");

})

</script>

<script type="text/javascript">
$(function(){  
     $('.navbar-static .hamburger-desktop .sr-only-show').text('ALL SECTIONS');      
 }); 
</script>

        </head>
        <body class="fixed-scroll-nav app-editorial grid-simple blox-asset uuid-6b37c6bc-5583-11eb-b85c-3b24571429a2 section-obituaries type-article infinity-summary-siderail" data-path="/obituaries">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.postguam.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=simple&amp;tncms.page.style=default&amp;tncms.page.path=%2Fobituaries&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.infinity_scroll.display=summary_siderail&amp;tncms.infinity_scroll.order=next&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=226&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.asset.id=6b37c6bc-5583-11eb-b85c-3b24571429a2&amp;tncms.asset.app=editorial&amp;tncms.google.ua=UA-93000716-1&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.postguam.com/tncms/admin/editorial-asset/?edit=6b37c6bc-5583-11eb-b85c-3b24571429a2"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-711033" class="tncms-block padding-top padding-left"><div class="follow-links-711033 default">
    
    <section id="block-711033" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/postguam" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/postguam" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="http://www.instagram.com/postguam" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
            <li>
                <a href="https://apps.apple.com/us/app/the-guam-daily-post/id1493963082" title="iOS App" target="_blank" rel="noopener" class="btn btn-xs btn-link io" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-app-store-ios"></i>
                    <span class="sr-only">iOS App</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://play.google.com/store/apps/details?id=com.postguam.android" title="Google Playstore App" target="_blank" rel="noopener" class="btn btn-xs btn-link ad" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-google-play"></i>
                    <span class="sr-only">Android App</span>
                </a>
            </li>
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.postguam.com",
  "sameAs" : ["https://www.facebook.com/postguam","https://twitter.com/postguam","http://www.instagram.com/postguam","https://apps.apple.com/us/app/the-guam-daily-post/id1493963082","https://play.google.com/store/apps/details?id=com.postguam.android"]
}
</script>
<div class="clearfix"></div></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/site/advertise.html"  class="nav-link tnt-section-advertise">Advertise</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&amp;edid=5bbcfb9b-0db9-4a89-a29b-a9a34fb9189a"  target="_blank" rel="noopener" class="nav-link tnt-section-e-edition">e-Edition</a>
                                </li><li>
                                    <a href="/users/admin/"  class="nav-link tnt-section-user-dashboard">User Dashboard</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/news/local/"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a href="/news/cnmi/"  class="nav-link tnt-section-cnmi">CNMI</a>
                                </li><li>
                                    <a href="/news/pacific"  class="nav-link tnt-section-pacific">Pacific</a>
                                </li><li>
                                    <a href="/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                                </li><li>
                                    <a href="/weather/"  class="nav-link tnt-section-weather">Weather</a>
                                </li><li>
                                    <a href="/site/forms/online_services/submit_news/"  class="nav-link tnt-section-submit-news">Submit News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-business">Business</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/business/local"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a href="/business/real_estate/"  class="nav-link tnt-section-real-estate">Real Estate</a>
                                </li><li>
                                    <a href="/business/"  class="nav-link tnt-section-world">World</a>
                                </li><li>
                                    <a href="/business/technology/"  class="nav-link tnt-section-technology">Technology</a>
                                </li><li>
                                    <a href="/stock_market/"  class="nav-link tnt-section-stock-market">Stock Market</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-forum">Forum</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/forum/editorial/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a href="/forum/featured_columnists/"  class="nav-link tnt-section-featured-columnists">Featured Columnists</a>
                                </li><li>
                                    <a href="/forum/letter_to_the_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a href="/site/forms/online_services/letter_editor/"  class="nav-link tnt-section-submit-a-letter">Submit a Letter</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-island-life">Island Life</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/site/event_calendar/"  class="nav-link tnt-section-community-calendar">Community Calendar</a>
                                </li><li>
                                    <a href="/island_life/maila_ta_fan_boka/"  class="nav-link tnt-section-maila-ta-fan-boka">Maila Ta Fan Boka</a>
                                </li><li>
                                    <a href="/island_life/spots_on_the_rock/"  class="nav-link tnt-section-spots-on-the-rock">Spots on the Rock</a>
                                </li><li>
                                    <a href="/island_life/the_scoop/"  class="nav-link tnt-section-the-scoop">The Scoop</a>
                                </li><li>
                                    <a href="/supplement/"  class="nav-link tnt-section-special-supplements">Special Supplements</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/local/"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a href="/sports/nation/"  class="nav-link tnt-section-nation">Nation</a>
                                </li><li>
                                    <a href="/sports/world/"  class="nav-link tnt-section-world">World</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-the-globe">The Globe</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="/the_globe/philippines_asia/"  class="nav-link tnt-section-philippinesasia">Philippines/Asia</a>
                                </li><li>
                                    <a href="/the_globe/nation/"  class="nav-link tnt-section-nation">Nation</a>
                                </li><li>
                                    <a href="/the_globe/world/"  class="nav-link tnt-section-world">World</a>
                                </li><li>
                                    <a href="/entertainment/food/"  class="nav-link tnt-section-food">Food</a>
                                </li><li>
                                    <a href="/entertainment/movies/"  class="nav-link tnt-section-movies">Movies</a>
                                </li><li>
                                    <a href="/entertainment/lifestyle/"  class="nav-link tnt-section-lifestyle">Lifestyle</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-multimedia">Multimedia</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a href="/multimedia/photo_gallery/"  class="nav-link tnt-section-photo-gallery">Photo Gallery</a>
                                </li><li>
                                    <a href="/multimedia/video_gallery/"  class="nav-link tnt-section-video-gallery">Video Gallery</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-9" data-target="#mobile-nav-left_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-subscription-services">Subscription Services</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/site/forms/subscription_services/subscribe/"  class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/unsubscribe/"  class="nav-link tnt-section-unsubscribe">Unsubscribe</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/paybill/"  class="nav-link tnt-section-pay-subscription-bill">Pay Subscription Bill</a>
                                </li><li>
                                    <a href="http://edition.pagesuite-professional.co.uk//launch.aspx?pbid=5357166a-437c-4b2c-9983-d9639655a6e7"  target="_blank" rel="noopener" class="nav-link tnt-section-e-edition-subscription">E-Edition Subscription</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/gift_subscribe/"  class="nav-link tnt-section-gift-subscribe">Gift Subscribe</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/change_address/"  class="nav-link tnt-section-change-of-address">Change of Address</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/delivery_issues/"  class="nav-link tnt-section-delivery-issues">Delivery Issues</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/vacation/"  class="nav-link tnt-section-vacation-stop-restart">Vacation Stop / Restart</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="https://www.postguam.com/search/?c=news%2A&amp;t=article&amp;nsa=eedition%3Fs%3Dstart_time&amp;sd=desc&amp;l=50&amp;f=rss"  target="_blank" rel="noopener" class="nav-link tnt-section-rss">RSS</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-965663" class="tncms-block"><div style="float: right;">    
<a href="https://www.postguam.com/site/forms/subscription_services/subscribe/" target="_blank"><font color="ffffff"><b>SUBSCRIBE</b></font></a>    
<a href="http://edition.pagesuite-professional.co.uk//launch.aspx?pbid=5357166a-437c-4b2c-9983-d9639655a6e7" target="_blank"><font color="ffffff"><b>E-EDITION</b></font></a>    
<a href="https://www.postguam.com/site/forms/subscription_services/paybill/" target="_blank"><font color="ffffff"><b>PAY BILL</b></font></a>    
<a href="https://www.postguam.com/site/contact.html" target="_blank"><font color="ffffff"><b>CONTACT US</b></font></a>    
</div></div><div id="tncms-block-701053" class="tncms-block"><div class="follow-links-701053 pull-right">
    
    <section id="block-701053" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/postguam" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/postguam" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="http://www.instagram.com/postguam" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.postguam.com",
  "sameAs" : ["https://www.facebook.com/postguam","https://twitter.com/postguam","http://www.instagram.com/postguam"]
}
</script>
<div class="clearfix"></div></div></div><div id="tncms-region-nav-topbar-col-two-nav" class="tncms-region-nav"><ul id="topbar-col-two-nav_menu" class="list-inline nav-list"></ul></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-701048" class="tncms-block"><section id="block-701048" class="block emphasis-h3   " ><div class="block">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/85de84bc-2b8e-11ea-939c-c7f5f6fe7b90.png?resize=200%2C39 200w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/85de84bc-2b8e-11ea-939c-c7f5f6fe7b90.png?resize=300%2C59 300w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/85de84bc-2b8e-11ea-939c-c7f5f6fe7b90.png?resize=400%2C79 400w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/85de84bc-2b8e-11ea-939c-c7f5f6fe7b90.png?resize=540%2C107 540w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/85de84bc-2b8e-11ea-939c-c7f5f6fe7b90.png?resize=750%2C148 750w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/85de84bc-2b8e-11ea-939c-c7f5f6fe7b90.png?resize=1200%2C237 1200w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/85de84bc-2b8e-11ea-939c-c7f5f6fe7b90.png?resize=1700%2C335 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></div></section></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-701050" class="tncms-block"><div align="right"><div style="width:100px;">
<a href="https://www.accuweather.com/en/gu/tamuning/96911/weather-forecast/183960" class="aw-widget-legal">
<!--
By accessing and/or using this code snippet, you agree to AccuWeather&rsquo;s terms and conditions (in English) which can be found at https://www.accuweather.com/en/free-weather-widgets/terms and AccuWeather&rsquo;s Privacy Statement (in English) which can be found at https://www.accuweather.com/en/privacy.
-->
</a><div id="awcc1520223247166" class="aw-widget-current" data-locationkey="183960" data-unit="f" data-language="en-us" data-useip="false" data-uid="awcc1520223247166" data-targeturl="http://www.postguam.com/weather"></div>
<script type="text/javascript" src="https://oap.accuweather.com/launch.js"></script>
</div></div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-701047" class="tncms-block"><div id="site-logo-701047" class="site-logo-container text-left" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/30b1dc1e-2b8e-11ea-a57c-9bb55e69a226.png?resize=200%2C39" 
            srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/30b1dc1e-2b8e-11ea-a57c-9bb55e69a226.png?resize=200%2C39 200w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/30b1dc1e-2b8e-11ea-a57c-9bb55e69a226.png?resize=300%2C59 300w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/30b1dc1e-2b8e-11ea-a57c-9bb55e69a226.png?resize=400%2C79 400w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/30b1dc1e-2b8e-11ea-a57c-9bb55e69a226.png?resize=540%2C106 540w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/30b1dc1e-2b8e-11ea-a57c-9bb55e69a226.png?resize=750%2C148 750w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/30b1dc1e-2b8e-11ea-a57c-9bb55e69a226.png 1200w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"></div>
    </div></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-701049" class="tncms-block"><ul id="site-search-701049-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-701049" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
        <input type="hidden" name="sd" value="desc">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-sm ">
        <input id="site-search-701049-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-701049-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-701049-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-701049').submit();
        return false;
    });

    $('#site-search-701049').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-701049 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-701049 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-701049-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-advertise"  href="/site/advertise.html" >
                    <span class="nav-label">Advertise</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="https://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&amp;edid=5bbcfb9b-0db9-4a89-a29b-a9a34fb9189a"  target="_blank" rel="noopener">
                    <span class="nav-label">e-Edition</span>
                </a></li><li>
                <a class="nav-link  tnt-section-user-dashboard"  href="/users/admin/" >
                    <span class="nav-label">User Dashboard</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local"  href="/news/local/" >
                    <span class="nav-label">Local</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cnmi"  href="/news/cnmi/" >
                    <span class="nav-label">CNMI</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pacific"  href="/news/pacific" >
                    <span class="nav-label">Pacific</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-news"  href="/site/forms/online_services/submit_news/" >
                    <span class="nav-label">Submit News</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-business"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Business</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local"  href="/business/local" >
                    <span class="nav-label">Local</span>
                </a></li><li>
                <a class="nav-link  tnt-section-real-estate"  href="/business/real_estate/" >
                    <span class="nav-label">Real Estate</span>
                </a></li><li>
                <a class="nav-link  tnt-section-world"  href="/business/" >
                    <span class="nav-label">World</span>
                </a></li><li>
                <a class="nav-link  tnt-section-technology"  href="/business/technology/" >
                    <span class="nav-label">Technology</span>
                </a></li><li>
                <a class="nav-link  tnt-section-stock-market"  href="/stock_market/" >
                    <span class="nav-label">Stock Market</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-forum"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Forum</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-editorials"  href="/forum/editorial/" >
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link  tnt-section-featured-columnists"  href="/forum/featured_columnists/" >
                    <span class="nav-label">Featured Columnists</span>
                </a></li><li>
                <a class="nav-link  tnt-section-letters-to-the-editor"  href="/forum/letter_to_the_editor/" >
                    <span class="nav-label">Letters to the Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-a-letter"  href="/site/forms/online_services/letter_editor/" >
                    <span class="nav-label">Submit a Letter</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-island-life"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Island Life</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-community-calendar"  href="/site/event_calendar/" >
                    <span class="nav-label">Community Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-maila-ta-fan-boka"  href="/island_life/maila_ta_fan_boka/" >
                    <span class="nav-label">Maila Ta Fan Boka</span>
                </a></li><li>
                <a class="nav-link  tnt-section-spots-on-the-rock"  href="/island_life/spots_on_the_rock/" >
                    <span class="nav-label">Spots on the Rock</span>
                </a></li><li>
                <a class="nav-link  tnt-section-the-scoop"  href="/island_life/the_scoop/" >
                    <span class="nav-label">The Scoop</span>
                </a></li><li>
                <a class="nav-link  tnt-section-special-supplements"  href="/supplement/" >
                    <span class="nav-label">Special Supplements</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local"  href="/sports/local/" >
                    <span class="nav-label">Local</span>
                </a></li><li>
                <a class="nav-link  tnt-section-nation"  href="/sports/nation/" >
                    <span class="nav-label">Nation</span>
                </a></li><li>
                <a class="nav-link  tnt-section-world"  href="/sports/world/" >
                    <span class="nav-label">World</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-the-globe"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">The Globe</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-philippinesasia"  href="/the_globe/philippines_asia/" >
                    <span class="nav-label">Philippines/Asia</span>
                </a></li><li>
                <a class="nav-link  tnt-section-nation"  href="/the_globe/nation/" >
                    <span class="nav-label">Nation</span>
                </a></li><li>
                <a class="nav-link  tnt-section-world"  href="/the_globe/world/" >
                    <span class="nav-label">World</span>
                </a></li><li>
                <a class="nav-link  tnt-section-food"  href="/entertainment/food/" >
                    <span class="nav-label">Food</span>
                </a></li><li>
                <a class="nav-link  tnt-section-movies"  href="/entertainment/movies/" >
                    <span class="nav-label">Movies</span>
                </a></li><li>
                <a class="nav-link  tnt-section-lifestyle"  href="/entertainment/lifestyle/" >
                    <span class="nav-label">Lifestyle</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-multimedia"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Multimedia</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-photo-gallery"  href="/multimedia/photo_gallery/" >
                    <span class="nav-label">Photo Gallery</span>
                </a></li><li>
                <a class="nav-link  tnt-section-video-gallery"  href="/multimedia/video_gallery/" >
                    <span class="nav-label">Video Gallery</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-subscription-services"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Subscription Services</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-subscribe"  href="/site/forms/subscription_services/subscribe/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-unsubscribe"  href="/site/forms/subscription_services/unsubscribe/" >
                    <span class="nav-label">Unsubscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pay-subscription-bill"  href="/site/forms/subscription_services/paybill/" >
                    <span class="nav-label">Pay Subscription Bill</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition-subscription"  href="http://edition.pagesuite-professional.co.uk//launch.aspx?pbid=5357166a-437c-4b2c-9983-d9639655a6e7"  target="_blank" rel="noopener">
                    <span class="nav-label">E-Edition Subscription</span>
                </a></li><li>
                <a class="nav-link  tnt-section-gift-subscribe"  href="/site/forms/subscription_services/gift_subscribe/" >
                    <span class="nav-label">Gift Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-change-of-address"  href="/site/forms/subscription_services/change_address/" >
                    <span class="nav-label">Change of Address</span>
                </a></li><li>
                <a class="nav-link  tnt-section-delivery-issues"  href="/site/forms/subscription_services/delivery_issues/" >
                    <span class="nav-label">Delivery Issues</span>
                </a></li><li>
                <a class="nav-link  tnt-section-vacation-stop-restart"  href="/site/forms/subscription_services/vacation/" >
                    <span class="nav-label">Vacation Stop / Restart</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-rss"  href="https://www.postguam.com/search/?c=news%2A&amp;t=article&amp;nsa=eedition%3Fs%3Dstart_time&amp;sd=desc&amp;l=50&amp;f=rss"  target="_blank" rel="noopener">
                    <span class="nav-label">RSS</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-776815" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-776815" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-776815');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-700842" class="tncms-block"></div><div id="tncms-block-822201" class="tncms-block"></div><div id="tncms-block-774550" class="tncms-block"><br></div><div id="tncms-block-723284" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-723284" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-723284');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div><div id="modal-image-0c95a426-557e-11eb-9aa0-f3b23b589fb9" class="modal fullscreen in modal-image image-mugshot modal-0c95a426-557e-11eb-9aa0-f3b23b589fb9" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-vertical letterbox-style-blur">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2"
                    srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=200%2C260&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=300%2C390&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=308%2C400&order=crop%2Cresize 400w"
                    sizes="100vw"
                    
                    width="308"
                    height="400"
                    alt="Reverend Riten Peter"
                    class="img-responsive true-size blur" />
                
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=200%2C260&order=crop%2Cresize" alt="" />
         </div>
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-0c95a426-557e-11eb-9aa0-f3b23b589fb9" data-target=".caption-inner-modal-image-0c95a426-557e-11eb-9aa0-f3b23b589fb9">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-0c95a426-557e-11eb-9aa0-f3b23b589fb9 collapse in"><div class="caption-text"><p><strong>Reverend Riten Peter</strong></p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Fimage_0c95a426-557e-11eb-9aa0-f3b23b589fb9.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/reverend-riten-peter/image_0c95a426-557e-11eb-9aa0-f3b23b589fb9.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0c95a426-557e-11eb-9aa0-f3b23b589fb9"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Reverend%20Riten%20Peter&via=postguam&url=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Fimage_0c95a426-557e-11eb-9aa0-f3b23b589fb9.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/reverend-riten-peter/image_0c95a426-557e-11eb-9aa0-f3b23b589fb9.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0c95a426-557e-11eb-9aa0-f3b23b589fb9"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.postguam.com/obituaries/reverend-riten-peter/image_0c95a426-557e-11eb-9aa0-f3b23b589fb9.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/reverend-riten-peter/image_0c95a426-557e-11eb-9aa0-f3b23b589fb9.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0c95a426-557e-11eb-9aa0-f3b23b589fb9"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.postguam.com/tncms/asset/editorial/0c95a426-557e-11eb-9aa0-f3b23b589fb9" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"0c95a426-557e-11eb-9aa0-f3b23b589fb9"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BGuam%20Daily%20Post%2C%20LLC%5D%20Reverend%20Riten%20Peter&body=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Fimage_0c95a426-557e-11eb-9aa0-f3b23b589fb9.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"0c95a426-557e-11eb-9aa0-f3b23b589fb9"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/reverend-riten-peter/image_0c95a426-557e-11eb-9aa0-f3b23b589fb9.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0c95a426-557e-11eb-9aa0-f3b23b589fb9"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-0c95a426-557e-11eb-9aa0-f3b23b589fb9-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="0c95a426-557e-11eb-9aa0-f3b23b589fb9" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="0c95a426-557e-11eb-9aa0-f3b23b589fb9" class="save-list-0c95a426-557e-11eb-9aa0-f3b23b589fb9-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="0c95a426-557e-11eb-9aa0-f3b23b589fb9" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-0c95a426-557e-11eb-9aa0-f3b23b589fb9 img { max-height: 400px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-6b37c6bc-5583-11eb-b85c-3b24571429a2" class="asset article-default"  data-url="https://www.postguam.com/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=308%2C400&order=crop%2Cresize">
            <meta itemprop="width" content="308">
            <meta itemprop="height" content="400">
        </div>
        <meta itemprop="name" content="postguam.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.postguam.com/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html" />
    <div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Reverend Riten Peter
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2021-01-14T00:00:00+10:00" class="tnt-date asset-date text-muted">
            Jan 14, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-01-14T00:00:00+10:00" class="tnt-date asset-date text-muted">1 hr ago</time></li>
        
        
            <li class="hidden-print"><a href="/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html#comments" class="cm" title="0 entries"><span class="fas tnt-book"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-01-14T00:00:00+10:00">
    <meta itemprop="datePublished" content="2021-01-14T00:00:00+10:00">
    <meta itemprop="dateModified" content="2021-01-14T00:00:00+10:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Farticle_6b37c6bc-5583-11eb-b85c-3b24571429a2.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Reverend%C2%A0Riten%20Peter&via=postguam&url=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Farticle_6b37c6bc-5583-11eb-b85c-3b24571429a2.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.postguam.com/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.postguam.com/tncms/asset/editorial/6b37c6bc-5583-11eb-b85c-3b24571429a2" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BGuam%20Daily%20Post%2C%20LLC%5D%20Reverend%C2%A0Riten%20Peter&body=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Farticle_6b37c6bc-5583-11eb-b85c-3b24571429a2.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    
        <div class="asset-related-mugshot inline-asset inline-image hover-expand visible-xs" data-photo-target=".photo-0c95a426-557e-11eb-9aa0-f3b23b589fb9" data-toggle="modal" data-instance="#gallery-items-6b37c6bc-5583-11eb-b85c-3b24571429a2-photo-modal" data-target="#photo-carousel-6b37c6bc-5583-11eb-b85c-3b24571429a2">
            <span class="expand"><span class="fas tnt-camera"></span>
            </span><figure class="photo layout-vertical letterbox-style-blur">
            <div class="image" 
                >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="308">
            <meta itemprop="height" content="400">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Reverend Riten Peter"
                            class="img-responsive lazyload full blur"
                            width="308"
                            height="400"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=200%2C260&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=300%2C390&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=308%2C400&order=crop%2Cresize 400w" />
            </div>
                
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=200%2C260&order=crop%2Cresize" alt="" />
         </div>
            </div>
            
                
                
                    <figcaption class="caption">
                            <span class="caption-text">
                                <p><strong>Reverend Riten Peter</strong></p>
                            </span>
                        
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>
    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"><div id="tncms-block-825536" class="tncms-block"><style>
#myBtn {
  display: none;
  position: fixed;
  bottom: 10px;
  right: 10px;
  z-index: 99;
  font-size: 18px;
  border: none;
  outline: none;
  background-color: #db3742;
  color: white;
  cursor: pointer;
  padding: 5px;
  border-radius: 4px;
}

#myBtn:hover {
  background-color: #555;
}
</style><button onclick="topFunction()" id="myBtn" title="Go to top">Back to Top</button><script>
//Get the button
var mybutton = document.getElementById("myBtn");

// When the user scrolls down 1000px from the top of the document, show the button
window.onscroll = function() {scrollFunction()};

function scrollFunction() {
  if (document.body.scrollTop > 1000 || document.documentElement.scrollTop > 1000) {
    mybutton.style.display = "block";
  } else {
    mybutton.style.display = "none";
  }
}

// When the user clicks on the button, scroll to the top of the document
function topFunction() {
  document.body.scrollTop = 0;
  document.documentElement.scrollTop = 0;
}
</script></div></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="6b37c6bc-5583-11eb-b85c-3b24571429a2" data-smart-adunit="/132916964/postguam.com/obituaries">
                

                <div class="row">
                    <div class="col-lg-8 col-md-12 col-sm-8 col-lg-push-4 col-md-push-0 col-sm-push-4" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Farticle_6b37c6bc-5583-11eb-b85c-3b24571429a2.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Reverend%C2%A0Riten%20Peter&via=postguam&url=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Farticle_6b37c6bc-5583-11eb-b85c-3b24571429a2.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.postguam.com/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.postguam.com/tncms/asset/editorial/6b37c6bc-5583-11eb-b85c-3b24571429a2" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BGuam%20Daily%20Post%2C%20LLC%5D%20Reverend%C2%A0Riten%20Peter&body=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Farticle_6b37c6bc-5583-11eb-b85c-3b24571429a2.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-6b37c6bc-5583-11eb-b85c-3b24571429a2-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="6b37c6bc-5583-11eb-b85c-3b24571429a2" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="6b37c6bc-5583-11eb-b85c-3b24571429a2" class="save-list-6b37c6bc-5583-11eb-b85c-3b24571429a2-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="6b37c6bc-5583-11eb-b85c-3b24571429a2" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p class="p1">Reverend Riten Peter, of Mangilao, died Jan. 2 at the age of 68. Viewing and last respects will be held from 9 a.m.-noon on Jan. 19 at Our Lady of Peace Memorial Chapel, Windward Hills, Yona. Interment services will follow immediately at Vicente Limtiaco "Tiguac" Cemetery, Nimitz Hill.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    
        
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Farticle_6b37c6bc-5583-11eb-b85c-3b24571429a2.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Reverend%C2%A0Riten%20Peter&via=postguam&url=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Farticle_6b37c6bc-5583-11eb-b85c-3b24571429a2.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.postguam.com/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.postguam.com/tncms/asset/editorial/6b37c6bc-5583-11eb-b85c-3b24571429a2" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BGuam%20Daily%20Post%2C%20LLC%5D%20Reverend%C2%A0Riten%20Peter&body=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Farticle_6b37c6bc-5583-11eb-b85c-3b24571429a2.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6b37c6bc-5583-11eb-b85c-3b24571429a2"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-6b37c6bc-5583-11eb-b85c-3b24571429a2-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="6b37c6bc-5583-11eb-b85c-3b24571429a2" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="6b37c6bc-5583-11eb-b85c-3b24571429a2" class="save-list-6b37c6bc-5583-11eb-b85c-3b24571429a2-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="6b37c6bc-5583-11eb-b85c-3b24571429a2" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div><div class="col-lg-4 col-md-12 col-sm-4 col-md-pull-0 col-sm-pull-8 col-lg-pull-8" data-subscription-required-remove>
                            <aside class="related-sidebar default  subscriber-hide">

                                

                                <div id="tncms-region-article_aside_top" class="tncms-region hidden-print"></div>

                                
                                

                                

                                

                                

                                
                                                <div class="asset-related-mugshot inline-asset inline-image hidden-xs">
                                                    <div class="hover-expand" data-toggle="modal" data-target=".modal-0c95a426-557e-11eb-9aa0-f3b23b589fb9">
                                                        <span class="expand"><span class="fas tnt-camera"></span>
                                                        </span><figure class="photo layout-vertical letterbox-style-blur">
            <div class="image" 
                >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="308">
            <meta itemprop="height" content="400">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Reverend Riten Peter"
                            class="img-responsive lazyload full blur"
                            width="308"
                            height="400"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=200%2C260&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=300%2C390&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=308%2C400&order=crop%2Cresize 400w" />
            </div>
                
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/0/c9/0c95a426-557e-11eb-9aa0-f3b23b589fb9/5ffeb778a0c28.image.jpg?crop=308%2C400%2C85%2C2&resize=200%2C260&order=crop%2Cresize" alt="" />
         </div>
            </div>
            
                
                
                    <figcaption class="caption">
                            <span class="caption-text">
                                <p><strong>Reverend Riten Peter</strong></p>
                            </span>
                        
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div></div>
                                            

                                

                                

                                

                                

                                

                                

                                <div id="tncms-region-article_aside_bottom" class="tncms-region hidden-print"></div>

                                

                                <div id="article-aside-sticky-spacer"><div id="tncms-region-article_aside_sticky" class="tncms-region hidden-print"></div></div>

                            </aside>
                        </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22riten%20peter%22#tncms-source=keyword" class="tag-riten-peter label label-default" data-tncms-track-dmp='search: riten-peter'>Riten Peter</a>
            </li> <li>
                <a href="/search/?k=%22last%20respects%22#tncms-source=keyword" class="tag-last-respects label label-default" data-tncms-track-dmp='search: last-respects'>Last Respects</a>
            </li> <li>
                <a href="/search/?k=%22christianity%22#tncms-source=keyword" class="tag-christianity label label-default" data-tncms-track-dmp='search: christianity'>Christianity</a>
            </li> <li>
                <a href="/search/?k=%22memorial%22#tncms-source=keyword" class="tag-memorial label label-default" data-tncms-track-dmp='search: memorial'>Memorial</a>
            </li> <li>
                <a href="/search/?k=%22yona%22#tncms-source=keyword" class="tag-yona label label-default" data-tncms-track-dmp='search: yona'>Yona</a>
            </li> <li>
                <a href="/search/?k=%22interment%22#tncms-source=keyword" class="tag-interment label label-default" data-tncms-track-dmp='search: interment'>Interment</a>
            </li> <li>
                <a href="/search/?k=%22mangilao%22#tncms-source=keyword" class="tag-mangilao label label-default" data-tncms-track-dmp='search: mangilao'>Mangilao</a>
            </li> <li>
                <a href="/search/?k=%22viewing%22#tncms-source=keyword" class="tag-viewing label label-default" data-tncms-track-dmp='search: viewing'>Viewing</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print"><a id="comments-collapsible-toggle" class="btn btn-block btn-lg btn-default"><i class="fas tnt-sync"></i> Load entries</a><div id="comments-collapsible" class="comments-container-collapsible collapsed">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Add an entry<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="6b37c6bc-5583-11eb-b85c-3b24571429a2" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Adding">Add entry</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your entry has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/obituaries/reverend-riten-peter/article_6b37c6bc-5583-11eb-b85c-3b24571429a2.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch the guestbook.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this guestbook.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="6b37c6bc-5583-11eb-b85c-3b24571429a2" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone signs the guestbook.
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this guestbook will end.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-book"></span> (0) entries 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Sign the guestbook.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.postguam.com/users/login/?referer_url=https%3A%2F%2Fwww.postguam.com%2Fobituaries%2Freverend-riten-peter%2Farticle_6b37c6bc-5583-11eb-b85c-3b24571429a2.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules">
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Add an entry</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch the guestbook.</span>
                                    <span class="unsubscribe">Stop watching this guestbook.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-700870" class="tncms-block"><section id="block-700870" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-700870 ">
        <div class="block-title-inner">
            <h3>
                
                Weekly Online Poll
                
            </h3>
        </div>
    </div>
    <div class="block-note block-note-700870 text-muted">
        <p>Poll results are published every Monday in The Guam Daily Post.</p>
    </div>
</div>
        
            
                <div class="poll-panel panel">
                    <div class="panel-body">
            
            <h4 class="tnt-headline ">
        
             <a href="/do-you-agree-with-changing-guams-senatorial-jobs-to-part-time/poll_8c816caa-51a1-11eb-baa9-eb130e7fb2c6.html" class="tnt-asset-link">
        

        
            Do you agree with changing Guam's senatorial jobs to part-time?</a></h4>
            <div id="poll-8c816caa-51a1-11eb-baa9-eb130e7fb2c6-700870" data-charted="false" class="card poll-content"><div class="loading-poll hide-onload text-center"><i class="fas tnt-spinner tnt-spin tnt-2x"></i></div>
            <div class="show-onload">
                <div id="poll-8c816caa-51a1-11eb-baa9-eb130e7fb2c6-700870-your-vote-container" class="alert alert-warning hide">
                    <strong>You voted:</strong> <span id="poll-8c816caa-51a1-11eb-baa9-eb130e7fb2c6-700870-your-vote"></span>
                </div>
                <div id="poll-8c816caa-51a1-11eb-baa9-eb130e7fb2c6-700870-results" class="tnt-poll-results hide"></div>
                <div id="poll-8c816caa-51a1-11eb-baa9-eb130e7fb2c6-700870-container">
                    <form id="poll-8c816caa-51a1-11eb-baa9-eb130e7fb2c6-700870-form" class="tnt-poll-form" role="form" method="post" action="/do-you-agree-with-changing-guams-senatorial-jobs-to-part-time/poll_8c816caa-51a1-11eb-baa9-eb130e7fb2c6.html">
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Yes" value="C93458F9-AA50-0001-65211A20C0708510"> Yes
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="No" value="C93458FB-6800-0001-5467174016F016EE"> No
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="I don't have enough information on the issue" value="C93458FC-1960-0001-5D2684A0EB001CA1"> I don't have enough information on the issue
                                </label>
                            </div>
                        
                        <button type="submit" class="btn btn-primary" >Vote</button>
                        <button id="poll-8c816caa-51a1-11eb-baa9-eb130e7fb2c6-700870-get-results" class="btn btn-default" >View Results</button>
                    </form>
                </div>
            </div>
            <div id="poll-8c816caa-51a1-11eb-baa9-eb130e7fb2c6-700870-back-vote" class="padding-top hide">
                <button id="poll-8c816caa-51a1-11eb-baa9-eb130e7fb2c6-700870-back-btn" class="btn btn-default">Back</button>
            </div>
        </div>
            
                    </div>
                </div>
            
        
    </section></div><div id="tncms-block-723290" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-723290" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-723290');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-700874" class="tncms-block"><div data-cswidget="8227"> </div>
<script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js"> </script><br></div><div id="tncms-block-700872" class="tncms-block"><section id="block-700872" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-700872 ">
        <div class="block-title-inner">
            <h3>
                
                Most Popular
                
            </h3>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-700872" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-700872" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-700872" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-700872" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc border border-dotted"><li><a href="/news/local/3-1m-in-tax-refunds-to-be-mailed-out/article_96deda48-516f-11eb-99f7-8f366111de3f.html">$3.1M in tax refunds to be mailed out</a></li><li><a href="/news/local/woman-charged-with-child-abuse-after-7-kids-found-alone/article_39f5ea56-516f-11eb-b822-773870aa8078.html">Woman charged with child abuse after 7 kids found alone</a></li><li><a href="/news/local/complaint-mendiola-broke-into-hotel-room-threatened-to-kill-woman/article_4a83bf66-517d-11eb-95a3-d7cb408643c2.html">Complaint: Mendiola broke into hotel room, threatened to kill woman</a></li><li><a href="/news/local/8-indicted-on-illegal-drug-possession-charges/article_1516f640-53d5-11eb-b0c0-bf69c3ce1ff4.html">8 indicted on illegal drug possession charges</a></li><li><a href="/news/local/man-scales-guam-airport-fence-reaches-jetway-and-tells-authorities-he-just-wanted-to-get/article_6f1c3c48-53cd-11eb-bc2b-4fe690d3d1f2.html">Man scales Guam airport fence, reaches jetway and tells authorities he 'just wanted to get out of the island'</a></li><li><a href="/news/local/navy-announces-7-companies-selected-for-990m-in-multiple-contracts-for-marines-relocation-to-guam/article_8ac66236-507e-11eb-abe5-336351949f77.html">Navy announces 7 companies selected for $990M in multiple contracts for Marines relocation to Guam</a></li><li><a href="/forum/editorial/meth-has-spread-to-community-that-once-dealt-only-with-alcoholism-what-will-it-take/article_86d80022-50aa-11eb-b475-d71dd6246fc5.html">Meth has spread to community that once dealt only with alcoholism. What will it take to stop drugs at the borders?</a></li><li><a href="/news/local/firefighter-tests-positive-for-covid-19-after-getting-vaccinated/article_3afa61c8-54be-11eb-9f07-cfc0aa9d2fe1.html">Firefighter tests positive for COVID-19 after getting vaccinated</a></li><li><a href="/news/local/man-arrested-in-child-molestation-case/article_c105af62-53c8-11eb-85f2-1b0a9fc12564.html">Man arrested in child molestation case</a></li><li><a href="/news/local/recorded-call-mailbox-for-drugs-goes-for-about-15k/article_afa859c0-518b-11eb-896c-3babb4e4e741.html">Recorded call: Mailbox for drugs goes for about $15K</a></li></ul></div>
        
        
            <div id="images-700872" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/submarine-ends-guam-deployment-moves-to-hawaii/image_3b72bd9e-5149-11eb-9ebd-676bc4e7a0c2.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Submarine ends Guam deployment, moves to Hawaii"
                            class="img-responsive lazyload full blur"
                            width="667"
                            height="667"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/3/b7/3b72bd9e-5149-11eb-9ebd-676bc4e7a0c2/5ff7aa7796dd7.image.jpg?crop=667%2C667%2C166%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/3/b7/3b72bd9e-5149-11eb-9ebd-676bc4e7a0c2/5ff7aa7796dd7.image.jpg?resize=200%2C133" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/submarine-visits-guam-from-washington-state/image_b8232448-54b2-11eb-83e1-f7f664ab08f1.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Submarine visits Guam from Washington state"
                            class="img-responsive lazyload full blur"
                            width="667"
                            height="667"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/b/82/b8232448-54b2-11eb-83e1-f7f664ab08f1/5ffd631dcd792.image.jpg?crop=667%2C667%2C166%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/b/82/b8232448-54b2-11eb-83e1-f7f664ab08f1/5ffd631dcd792.image.jpg?resize=200%2C133" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/sailors-take-part-in-southern-high-cleanup/image_c07cd1bc-5196-11eb-8831-1b2a80bec2e3.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Sailors take part in Southern High cleanup"
                            class="img-responsive lazyload full blur"
                            width="500"
                            height="500"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/c/07/c07cd1bc-5196-11eb-8831-1b2a80bec2e3/5ff82e9da1d79.image.jpg?crop=500%2C500%2C125%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/c/07/c07cd1bc-5196-11eb-8831-1b2a80bec2e3/5ff82e9da1d79.image.jpg?resize=200%2C133" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/salon-fusion-donates-5k-to-salvation-army/image_1a6c80ee-5275-11eb-925b-1717cace5c06.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Salon Fusion donates $5K to Salvation Army"
                            class="img-responsive lazyload full blur"
                            width="853"
                            height="853"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/1/a6/1a6c80ee-5275-11eb-925b-1717cace5c06/5ff9a0105c097.image.jpg?crop=853%2C853%2C213%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/1/a6/1a6c80ee-5275-11eb-925b-1717cace5c06/5ff9a0105c097.image.jpg?resize=200%2C133" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/community-first-donates-to-ramp-fund/image_c0ae8798-5182-11eb-8d27-c31041e1bfe5.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Community First donates to RAMP fund"
                            class="img-responsive lazyload full blur"
                            width="1080"
                            height="1080"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/c/0a/c0ae8798-5182-11eb-8d27-c31041e1bfe5/5ff80ae7db7bc.image.jpg?crop=1080%2C1080%2C419%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/c/0a/c0ae8798-5182-11eb-8d27-c31041e1bfe5/5ff80ae7db7bc.image.jpg?resize=200%2C113" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/dfs-donates-to-harvest-house/image_2645cbb4-5315-11eb-97bc-8b57a8e0d61d.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="DFS donates to Harvest House"
                            class="img-responsive lazyload full blur"
                            width="960"
                            height="960"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/2/64/2645cbb4-5315-11eb-97bc-8b57a8e0d61d/5ffaaee18354f.image.jpg?crop=960%2C960%2C160%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/2/64/2645cbb4-5315-11eb-97bc-8b57a8e0d61d/5ffaaee18354f.image.jpg?resize=200%2C150" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/man-who-fell-off-jet-ski-rushed-to-naval-hospital/image_5205909e-5307-11eb-b514-b38b59028b2d.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Man who fell off Jet Ski rushed to Naval Hospital"
                            class="img-responsive lazyload full blur"
                            width="551"
                            height="551"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/5/20/5205909e-5307-11eb-b514-b38b59028b2d/5ffa953a1a6de.image.jpg?crop=551%2C551%2C575%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/5/20/5205909e-5307-11eb-b514-b38b59028b2d/5ffa953a1a6de.image.jpg?resize=200%2C65" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/rampy-named-navy-medicine-s-clinical-social-work-officer-of-the-year-for-2020/image_b92a02e4-5309-11eb-8ce0-3ff4c03e9b93.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Rampy named Navy Medicine’s Clinical Social Work Officer of the Year for 2020"
                            class="img-responsive lazyload full blur"
                            width="667"
                            height="667"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/b/92/b92a02e4-5309-11eb-8ce0-3ff4c03e9b93/5ffa9a371c922.image.jpg?crop=667%2C667%2C166%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/b/92/b92a02e4-5309-11eb-8ce0-3ff4c03e9b93/5ffa9a371c922.image.jpg?resize=200%2C133" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/business/local/gas-prices-jump-again/image_d3c14222-530c-11eb-8790-b71c1eae236e.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Gas prices jump again"
                            class="img-responsive lazyload full blur"
                            width="720"
                            height="720"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/d/3c/d3c14222-530c-11eb-8790-b71c1eae236e/5ffa9e86d7fe3.image.jpg?crop=720%2C720%2C0%2C280&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/d/3c/d3c14222-530c-11eb-8790-b71c1eae236e/5ffa9e86d7fe3.image.jpg?resize=200%2C356" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/catholics-celebrate-santo-ni-o-festival-in-dededo/image_27d7c4e0-5334-11eb-9935-c38bd3aefd51.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Catholics celebrate Santo Niño Festival in Dededo"
                            class="img-responsive lazyload full blur"
                            width="853"
                            height="853"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/2/7d/27d7c4e0-5334-11eb-9935-c38bd3aefd51/5ffae1b0863ce.image.jpg?crop=853%2C853%2C213%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/2/7d/27d7c4e0-5334-11eb-9935-c38bd3aefd51/5ffae1b0863ce.image.jpg?resize=200%2C133" alt="" />
         </div>
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-700872" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/traffic-leading-to-okkodo-high-gridlocked-about-150-people-lining-up-for-vaccine-diverted-to/video_3189357a-509e-11eb-8c03-4f41e0e91aaf.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Traffic leading to Okkodo High gridlocked, about 150 people lining up for vaccine diverted to GRMC"
                            class="img-responsive lazyload full blur"
                            width="352"
                            height="352"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/3/18/3189357a-509e-11eb-8c03-4f41e0e91aaf/5ff68b7284c11.image.jpg?crop=352%2C352%2C144%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/3/18/3189357a-509e-11eb-8c03-4f41e0e91aaf/5ff68b7284c11.image.jpg?resize=200%2C110" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/local/off-island-care/video_b0ac77b6-5465-11eb-8f59-57cc2559955b.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="OFF-ISLAND CARE"
                            class="img-responsive lazyload full blur"
                            width="704"
                            height="704"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/b/0a/b0ac77b6-5465-11eb-8f59-57cc2559955b/5ffce2eb0b074.image.png?crop=704%2C704%2C282%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/b/0a/b0ac77b6-5465-11eb-8f59-57cc2559955b/5ffce2eb0b074.image.png?resize=200%2C111" alt="" />
         </div>
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-blur">
            <div class="image" 
                >
                
                    <a href="/news/national/see-what-trump-supporters-had-to-say-after-chaos-at-capitol-hill/video_2bbcc197-daa7-5a53-9eb7-2818d63b21fc.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="See what Trump supporters had to say after chaos at Capitol Hill"
                            class="img-responsive lazyload full blur"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/2/bb/2bbcc197-daa7-5a53-9eb7-2818d63b21fc/5ff66efe53437.image.jpg?crop=324%2C324%2C126%2C0&resize=100%2C100&order=crop%2Cresize 100w" />
                </a>
                <div class="tnt-blurred-image">
             <img src="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/assets/v3/editorial/2/bb/2bbcc197-daa7-5a53-9eb7-2818d63b21fc/5ff66efe53437.image.jpg?resize=200%2C113" alt="" />
         </div>
            </div>
            
        </figure></li>
                        </ul></div>
        
        
        
        
    </div>
</div></section></div><div id="tncms-block-723291" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-723291" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-723291');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-721839" class="tncms-block"><section id="block-721839" class="block emphasis-h2    tnt-no-margin-bottom" ><div class="clearfix">
    
    <div class="block-title title-721839 ">
        <div class="block-title-inner">
            <h2>
                
                    <a href="https://www.postguam.com/forum/editorial/">
                
                Opinion
                
                    </a>
                
            </h2>
        </div>
    </div></div><div class="card-bg-color ">
        
            
                <div class="card-panel panel">
                    <div class="panel-body">
            
            <article id="card-showcase-f1653758-5568-11eb-b93c-eb78da479290" class="clearfix card showcase position-0 odd  tnt-section-forum tnt-sub-section-editorial">
            <div class="card-container"><div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/forum/editorial" class="tnt-section-tag">Editorials</a>
                </div>
            
            </div><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/forum/editorial/vaccinated-guam-residents-need-to-keep-wearing-masks/article_f1653758-5568-11eb-b93c-eb78da479290.html" class="tnt-asset-link">
        

        
            Vaccinated Guam residents need to keep wearing masks</a></h3></div>
                    
                        <div class="card-lead">
                            <p>By today, there will be close to 11,000 doses of the Pfizer or Moderna vaccine against COVID-19 that have been administered to thousands of Gu&hellip; <a href="/forum/editorial/vaccinated-guam-residents-need-to-keep-wearing-masks/article_f1653758-5568-11eb-b93c-eb78da479290.html" class="tnt-asset-link read-more-link">Read more</a></p>
                        </div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
                    </div>
                </div>
            
        
    </div></section></div><div id="tncms-block-721841" class="tncms-block"><section id="block-721841" class="block emphasis-h3    tnt-no-margin-bottom" ><div class="card-bg-color ">
        
            
                <div class="card-panel panel">
                    <div class="panel-body">
            
            <article id="card-showcase-3b849b00-5553-11eb-bb86-23afa3c65add" class="clearfix card showcase position-0 odd  tnt-section-forum tnt-sub-section-featured-columnists">
            <div class="card-container"><div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/forum/featured_columnists" class="tnt-section-tag">Featured Columnists</a>
                </div>
            
            </div><div class="tnt-kicker kicker text-muted">Writings on the Wall</div><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/forum/featured_columnists/guam-education-leaders-collaborating-innovating-to-meet-local-needs/article_3b849b00-5553-11eb-bb86-23afa3c65add.html" class="tnt-asset-link">
        

        
            Guam education leaders collaborating, innovating to meet local needs</a></h3></div><div class="card-meta">
            <ul class="list-inline">
                        <li class="card-byline text-muted"><span  class="tnt-byline">Ron McNinch</span></li></ul>
        </div>
                    
                        <div class="card-lead">
                            <p>Over 40 years ago, the draft Guam Constitution had some interesting ideas on education. In addition to an elected school board for elementary &hellip; <a href="/forum/featured_columnists/guam-education-leaders-collaborating-innovating-to-meet-local-needs/article_3b849b00-5553-11eb-bb86-23afa3c65add.html" class="tnt-asset-link read-more-link">Read more</a></p>
                        </div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
                    </div>
                </div>
            
        
    </div></section></div><div id="tncms-block-721840" class="tncms-block"><section id="block-721840" class="block emphasis-h3    tnt-no-margin-bottom" ><div class="card-bg-color ">
        
            
                <div class="card-panel panel">
                    <div class="panel-body">
            
            <article id="card-showcase-6e9a7940-4fd3-11eb-be16-f37bedc753c1" class="clearfix card showcase position-0 odd  tnt-section-forum tnt-sub-section-letter-to-the-editor">
            <div class="card-container"><div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/forum/letter_to_the_editor" class="tnt-section-tag">Letters to the Editor</a>
                </div>
            
            </div><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/forum/letter_to_the_editor/charge-for-bags-and-generate-money-for-recycling/article_6e9a7940-4fd3-11eb-be16-f37bedc753c1.html" class="tnt-asset-link">
        

        
            Charge for bags and generate money for recycling</a></h3></div><div class="card-meta">
            <ul class="list-inline">
                        <li class="card-byline text-muted"><span  class="tnt-byline">Paul Tobiason</span></li></ul>
        </div>
                    
                        <div class="card-lead">
                            <p>We now have the plastic bag ban in effect. So where do we think the many pallets of plastic bags in warehouses are now going to go? My observa&hellip; <a href="/forum/letter_to_the_editor/charge-for-bags-and-generate-money-for-recycling/article_6e9a7940-4fd3-11eb-be16-f37bedc753c1.html" class="tnt-asset-link read-more-link">Read more</a></p>
                        </div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
                    </div>
                </div>
            
        
    </div></section></div><div id="tncms-block-723292" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-723292" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-723292');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article><div id="infinite-container" class="infinity-summary-container hidden-print">
        <div id="infinite-more" data-next-url="https://www.postguam.com/tncms/search/mlt/?origin=6b37c6bc-5583-11eb-b85c-3b24571429a2&app=editorial&inline=infinity&type=article%2Ccollection%2Cvideo%2Cyoutube">
            <i class="fas tnt-spinner tnt-pulse"></i>
        </div>
    </div>

    <script>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</script>
    
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-700837" class="tncms-block"><section id="block-700837" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-700837 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-the-globe"  href="/the_globe/" >
                    <span class="nav-label">The Globe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-forum"  href="/forum/" >
                    <span class="nav-label">Forum</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community"  href="/community/" >
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link  tnt-section-multimedia"  href="/multimedia/" >
                    <span class="nav-label">Multimedia</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-features"  href="/online_features/" >
                    <span class="nav-label">Online Features</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-700841" class="tncms-block"><section id="block-700841" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-700841 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-privacy-policy"  href="/site/privacy.html" >
                    <span class="nav-label">Privacy Policy</span>
                </a></li><li>
                <a class="nav-link  tnt-section-terms-of-service"  href="/site/terms.html" >
                    <span class="nav-label">Terms of Service</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertising"  href="/site/advertise.html" >
                    <span class="nav-label">Advertising</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscription-services"  href="/site/forms/subscription_services/" >
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="http://edition.pagesuite-professional.co.uk//launch.aspx?pbid=5357166a-437c-4b2c-9983-d9639655a6e7"  target="_blank" rel="noopener">
                    <span class="nav-label">e-Edition</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-711025" class="tncms-block"><section id="block-711025" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-711025 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div></section></div><div id="tncms-block-700839" class="tncms-block padding-bottom"><section id="block-700839" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/10165e4e-2b8e-11ea-af4a-5f27d1fe9afe.png?resize=200%2C40 200w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/10165e4e-2b8e-11ea-af4a-5f27d1fe9afe.png?resize=300%2C59 300w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/10165e4e-2b8e-11ea-af4a-5f27d1fe9afe.png?resize=400%2C79 400w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/10165e4e-2b8e-11ea-af4a-5f27d1fe9afe.png?resize=540%2C107 540w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/10165e4e-2b8e-11ea-af4a-5f27d1fe9afe.png?resize=750%2C148 750w, https://bloximages.newyork1.vip.townnews.com/postguam.com/content/tncms/custom/image/10165e4e-2b8e-11ea-af4a-5f27d1fe9afe.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-700838" class="tncms-block"><section id="block-700838" class="block emphasis-h4   " ><address>
    <strong>www.PostGuam.com</strong><br>
    388 S. Marine Corps Drive, Suite 301<br>
    Tamuning, Guam 96913
    <br>
    
        <strong>Phone:</strong> (671) 649-1924<br>
        <strong>Email:</strong> <a href="mailto:webmaster@postguam.com">webmaster@postguam.com</a><br>
    
</address></section></div><div id="tncms-block-700840" class="tncms-block padding-bottom"><div class="follow-links-700840 default">
    
    <section id="block-700840" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-700840 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/postguam" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/postguam" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="http://www.instagram.com/postguam" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.postguam.com",
  "sameAs" : ["https://www.facebook.com/postguam","https://twitter.com/postguam","http://www.instagram.com/postguam"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("6b37c6bc-5583-11eb-b85c-3b24571429a2")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc13632.add('act', dmpData);_cc13632.bcp();
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.dff62462821a09a08cb5a44c8d59b2ea.js"></script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ $("#comments-collapsible-toggle").click(function() { $("#comments-collapsible, #comments-collapsible-toggle").toggleClass("collapsed"); }); /*]]>*/</script>
<script>/*<![CDATA[*/ function dmpAction(dmpData) {_cc13632.add('act', dmpData);_cc13632.bcp();} /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/postguam.com/shared-content/art/tncms/templates/libraries/flex/components/editorial/resources/scripts/tnt.poll.aa4a56a35da582e986ed8bbce2004ea4.js"></script>
<script>/*<![CDATA[*/ 
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc13632.add('act', dmpData);_cc13632.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>